Mobile version showing blank groups

For feature requests, please see:

For troubleshooting questions, please post in the following format:

On mobile, clicking notifications temporarily shows a message in MM and then shows an empty group

Steps to reproduce
This doesn’t seem to be happening for others on my team. For me:

  1. Get a MM notification (on Android).
  2. Select the notification and get taken to MM where the message is visible
  3. A few seconds later, the message disappears and the entire group looks empty with no messages displaying

Expected behavior
#3, above, does not happen

Observed behavior
I see the following: a notification I then click on:

Mattermost loads (always see the loading screen!) and presents the message:

Get a loading sign and then the group appears as empty:

Hi @aagha786,

this could be a local cache issue of your application. The mattermost mobile app has its own internal database and it’s worth a try to flush it to see if this helps with your issue.
What helped me in the past was to logout of the server profile and log back in again, which seems to do something to the local database - can you try that please on your mobile device to see if that changes the behaviour?

Thanks @agriesser . Just tried that, but no dice.

I also cleared Android cache and storage. (In the past, I tried to uninstall the app and re-install it).

Now, the functionality has changed a bit. Clicking on a (“Business Development”) notification, I’m being taken to the main Metrical channel, without the channel being selected:

Can you try to swipe to the left and back, drag the open channel view up to force a refresh of the posts in the channel or close theapp and go back into the channel then; does sny of these actions bring the missing post back?

Swiping left and back doesn’t change the screen in any way–is there supposed to be side-swipe action?!

Swiping up does refresh the channel.

On iOS there is, when you swipe from the left end of your screen to the right when you’re in a channel, you leave it and go back to the channel overview.

Refreshing the channel also did not help, right?


No, refreshing the channel doesn’t help.

Not only that, but the issues are just compounding:

After clicking on a Notification, the channel text appears and then suddenly the channel looks empty:

Now constantly get this error message:

From inside Android, if I screenshot something and share with a channel in MM, I get this error:

For the record, I don’t have ANY problems with the desktop client, so we can rule out our MM server of the desktop version of the app.

Thanks for the additional information.
Can you please confirm the build number of your app? There has been an update recently and I just want to make sure that you’re using the most recent version (or check your Playstore for an update first, please).

If you’re already on the most recent version and the problem still persists, please try to logout of your server profile in the Mattermost application and log back in. This will clear the local database of posts, channels, etc. of the app and might also fix the issues you’re seeing.

Maybe there is another thread for this, but for me, I think ever since the 2.0 mobile app release on Android that happened earlier this year, things have been pretty wonky. I currently have the latest version available to me in the app store, 2.1.0.

Sometimes it says teams don’t exist. Sometimes teams show up blank. Sometimes channels show up blank. Sometimes channels stop updating. Sometimes messages are delayed. Sometimes messages don’t send (get an immediate red !), a resend normally works but not always, and then sometimes it sends twice.

Happens both on Wifi and cell network.

We have a self-hosted server, nearly up-to-date at 7.8.0.

Desktop app or web interface through a browser works fine.

Today I completely removed the MM mobile app and re-installed to see if that helps somehow.

Hey @luckyj and welcome to the Mattermost forums!

Thanks for adding this information here, did your profile also get wiped after the reinstall? Did you have to re-create the profile or did the application find the old profile and let you reuse it?

I’m not sure if I know what you’re referring to as a profile - but when I started Mattermost on my phone after the re-install, it seemed to act like I installed it for the first time. I had to configure the server to connect to (URL and name) and enter my credentials again.

But sadly that reinstall didn’t help - still having issues. :frowning:

I forgot to mention that frequently swiping up doesn’t refresh a channel. Instead, I have to scroll up in the conversation a little, then back down, and then swipe up. Sometimes twice. And sometimes if I open a channel, and then wait for a bit (10 seconds or so), messages will suddenly appear.

I’ve started using the mobile app less and less because of this - I’m just about at the point where I can’t rely on it anymore. This same issue is happening to other Android users on our server, so it’s not just my phone.

My next experiment is testing an old version of the mobile app.

I uninstalled the 2.1 version from the app store, and I installed the apk for 1.55.1 from Releases · mattermost/mattermost-mobile · GitHub. Logged into the server and I’m initially noticing a difference already. Channels populated messages pretty much instantly as I navigated around. That did not happen with the 2.1 version.

We’ll see how this goes…


I’ve tried uninstalling the mobile app and logging out of the desktop app and logging back in. Is that what you mean re resetting the profile?

Yes, that’s what I meant with resetting the profile - I assume things have not changed for your now after doing that, right?

That’s correct. Nothing has changed.

Alright, sorry to hear that.
Can you please send yourself the logs from the application via e-mail and attach them here?

How do I do that on my phone?

After you’re logged in to one of the profiles on your app, tap on your profile picture on the bottom right, click on advanced settings and then you’ll find a “report a problem” link at the bottom, which will open your default mail application with the logs attached.

Here you go:

Thanks, I can see the following relevant messages in your log:

2023/03/03 11:34:01.898 ERROR FetchPostsForChannel {
  "jsEngine": "hermes",
  "status_code": 429,
  "url": "\/api\/v4\/channels\/ggii5hyp83yx3gjnsenrs3et7c\/posts?page=0&per_page=60&collapsedThreads=false&collapsedThreadsExtended=false",
  "message": ""

→ HTTP 429 means “Too many requests”, so your app is being slowed down by the server.

2023/03/03 11:34:01.893 WARN  Handling Javascript error FetchPostsForChannel false
2023/03/03 11:34:01.894 ERROR FetchPostsForChannel {
  "jsEngine": "hermes",
  "status_code": 403,
  "server_error_id": "api.user.view_archived_channels.get_posts_for_channel.app_error",
  "url": "\/api\/v4\/channels\/oenb3dhdkjbiik5ndop4wgqzsy\/posts?page=0&per_page=60&collapsedThreads=false&collapsedThreadsExtended=false",
  "message": "Cannot retrieve posts for an archived channel"

→ You do seem to have some archived channels in your channel list which cannot be queried from the mobile app, not sure why, will have to find out, but according to the icon of the channels in question, they do not seem to be archived.
Can you provide the channel IDs for one of the channels in questions so I can see if there’s a corresponding line in the logs? Unfortunately the logs do not contain the names but only the IDs.
To get the ID, visit the channel in your browser and copy it out of the URL or open it in your desktop app and click on “View Info” which will open the channel info sidebar, it contains the “ID”.

Can you verify that you’re able to access archived channels in the web- or desktop app on your server? Maybe there’s a server side configuration to disallow access to archived channels for your users and the mobile app just doesn’t handle them properly.