[SOLVED] How to use Plesk's Let's Encrypt

I would like to install Mattermost without using Docker using Plesk. I did not install it to /opt and installed under the site. ex: /var/vhosts/MAINSITE/mattermost/. I made all the settings and confirmed the initial function.

Create an account and confirm it by email. However, I can not set it up as a manager. I am waiting for someone’s solicitation. Perhaps I am missing the setting.
The big problem, however, is that SSL/TLS connection is not possible. Plesk incorporates the features of Let’s Encrypt. That is, I can not set Let’s encrypt obediently. I can not match the authority of Plesk’s certificate by installing it in / opt. By installing in the site, I can maintain the authority of Plesk’s certificate.
I am currently doing HTTPS connection itself. But I can not access Mattermost. Connection refused. This is the same even if I forcefully induce it in https in nginx.conf. I can use mattermost if I give up https. How can I use Plesk’s Let’s encrypt? I guess the setting method is incorrect.

If I enable Let’s encrypt and foward80to443 in config.json, it will be rejected if the 8065 port is waiting for a connection. How do I avoid this? Currently I set these to false. TLSCertFile and TLSKeyFile are “/usr/local/psa/var/certificates/CERTFILE”. Since I can not access SiteURL items by starting with https://, I am starting with http://.

Please help.

CentOS 7.5 / nginx 1.13.8 / MariaDB 10.1.34 / Plesk Onyx 17.8.11

Hi @Babbles! Thank you for reaching out.

Did you follow any specific Mattermost installation guide while working on this?

I also found this troubleshooting thread that might help: https://talk.plesk.com/threads/websocket-error-400-docker-nginx.342596/.

1 Like

I tried searching on Google, including officials, and there were various ways. However, there was no content using Plesk. As I am few, I also looked at the links that you introduced. Is it related to using Plesk’s Let’s Encrypt?

Hi @Babbles!

I took a look at Plesk’s website and it looks like they have lot of information on Let’s Encrypt - perhaps taking a look at their documentation might help:


1 Like

Thank you for your reply. There are many requirements that I should look through. Plesk is inconvenient in such a situation. :smile:

Currently I forgot to encrypt once, trying basic setting of Mattermost. I didn’t think that Mattermost was so difficult. It doesn’t progress smoothly.
When I log out, even a user with administrator privileges can’t access the system console. Last time I wrote, someone waiting for an invitation. I either change the config.json directly, delete all MySQL tables, restart Mattermost with SSH, and access the top hierarchy with a web browser. When I looked at MySQL, I was able to confirm that the system administrator was given to that user.

And Web Socket’s 403 error doesn’t stop. No matter how I change nginx’s proxy I have not changed at all. Currently visible part of me, redirecting to HTTPS is blocking. Even so, Mattermost is trying to redirect to HTTPS. Is this one of the causes? In other words, it is a problem before Let’s Encrypt? I’m a mystery because Mattermost try to redirect even if I change browser or PC itself.

'ws://MY-IPADDRESS:8065/api/v4/websocket' failed: Error during WebSocket handshake: Unexpected response code: 403

Official installation guide, guidance provided by users searched by Google. There are many variations. This is a nuisance. Even the official guide has different actual directory structure.

I’m expecting this software. I’m grateful to the author who is providing it. I will try more trial and error.

I seem to have problems with redirecting to 8065 port. An error occurs in the occurrence of many redirects. I think that should probably be adjusted in config.json. How can I prevent multiple redirects?

To moderator,

Please DELETE this topic.
Excuse me. It was a topic different from the essence at all. It was a problem before Let’s Encrypt.