[SOLVED] Issues with upgrading

I’ve just updated from 4.5 to 4.8 (using the docker stack) and now the upload function crashes the prod-app container.

As the app crashes nothing is thrown into the app log, a few minutes later I can see the container respawning

[2018/03/19 11:20:30 UTC] [INFO] Loaded system translations for 'en' from '/mattermost/i18n/en.json'
[2018/03/19 11:20:30 UTC] [INFO] Server is initializing...
[2018/03/19 11:20:30 UTC] [INFO] Pinging SQL master database
[2018/03/19 11:20:31 UTC] [INFO] Current version is 4.8.0 (4.8.0/Thu Mar 15 23:11:12 UTC 2018/d1ed79a66c7930020b7fda046a11050f5890c84e/6f563c1fa497d123134fd499eb37674eb2511325)
[2018/03/19 11:20:31 UTC] [INFO] Enterprise Enabled: true
[2018/03/19 11:20:31 UTC] [INFO] Current working directory is /mattermost
[2018/03/19 11:20:31 UTC] [INFO] Loaded config file from /mattermost/config/config.json
[2018/03/19 11:20:32 UTC] [INFO] Connection to S3 or minio is good. Bucket exists.
[2018/03/19 11:20:32 UTC] [INFO] License key from https://mattermost.com required to unlock enterprise features.
[2018/03/19 11:20:32 UTC] [INFO] Starting up plugins
[2018/03/19 11:20:32 UTC] [WARN] unable to create user namespace: fork/exec /proc/self/exe: operation not permitted

I had this issue before when I tried to setup my own reverse-proxy. I’ve reverted to the MM provided one which fixed the problem back in the day. Now not even that is saving me :frowning:

If it’s relevant this is running on AWS Elasticbeanstalk.

Any tips on how I can troubleshoot this? Thank you.

Turns out the container had a hard memory limit of 1GB and uploads were reaching this threshould leading to the container being killed. Removed the hard limit and now all is good.