[SOLVED] Save button disabled on settings page, upon first run of app on Mac OS X


When the desktop app is run for the first time, the settings page appears and the Save button is disabled.

Steps to reproduce

Install v3.5.0 of the desktop app on Mac OS X 10.12.3, using the install package in the tar.gz file.
Run the app, by double-clicking the icon in the Applications folder.
The Settings page appears.
The ‘Save’ button is disabled.
There is no way to get the app to continue.
Even clicking ‘Cancel’ button or the ‘X’ (close) button does not continue on to the next page (whatever that should be).
Even cancelling the settings, quitting the app, and restarting that app just comes back to the settings page.
So there is no way to send/receive messages.

Expected behavior

It should save the settings and continue to the next screen, to allow the user to send and receive messages.

Observed behavior

No error messages.
And no log file found.
There is no way to get past the Settings page.

Be advised, I just noticed that v3.6 was available for Mac OS X, so I just installed it and it worked.
So I guess this can be ignored.

Hi @quazar0

Thanks for your report and also posting back to let us know that your issue had been solved by installing the latest version of the desktop app!