Welcome screen disable?

After upgrading the Windows client to 5.2, the app always shows the Welcome screen on every start. Clicking “Get Started” goes to where you enter a server and name, and simply pressing ESC gets rid of it. The server info is already auto-set using GPO.

I swear I’ve seen some kind of ‘welcome screen’ setting somewhere in the past. Was I imagining it? Is there any way to stop that screen from coming up every time the app is started?


Server is 7.4 (Enterprise in ‘free’ mode) on Ubuntu 18.04.

I believe if the user either completes the onboarding or clicks Skip Onboarding, then it won’t show again.

I found the “Enable Onboarding” setting in Experimental Features and switched that to Off. We’re still seeing the Welcome screen whenever Mattermost (v 5.2) starts, with no option to skip other than hitting ‘Esc’ or entering in server information again (which is already there so it doesn’t really do anything to add again).


EDIT: I found someone else reported on Github: https://github.com/mattermost/desktop/issues/2335

1 Like

Can confirm that we are also having the same issue, server would be inputted and every time you close mattermost you get the welcome screen again… Also you can see the servers in the server list as already added