Mattermost Desktop: Does not login to server automatically

Multiple users are having this issue on our server.

When our computers boot up, the desktop app opens, but does not automatically login to the server. Each time we start, we must go to File->Settings, and click on the only server in our “Server Management” list.

User adoption is our top priority, and we find that users do not take the time to login each time they start their computer because it is a manual step and they generally forget.

Is this a bug / setting I am missing (“Start App on login” is checked)? Or is this how it is supposed to work? Other users claim they do not have this issue.

What desktop app version and Mattermost server version are you on?
Is this on Windows, Mac or Linux, and which OS version?

Windows 7 and Windows 10 (we upgraded recently, doesn’t work on either). We are on the latest version of the server and Desktop version is 4.3.0

“Start App on login” setting means that when you reboot or start your computer/machine, then Mattermost should automatically open (not log in). What you described in your first post is the expected behaviour.