Android / Unexpected error

Hello, I have an error in my connection since the last update. I have a OnePlus 5 and the latest Mattermost update.
After login, I have this error: "Unexpected error"

I don’t understand…Thank you.

What Mattermost server version are you on?

Do you have “ExperimentalStrictCSRFEnforcement” setting enabled on your server?

Also if there is no confidential data, would you mind posting a screenshot for the default channel (normally town-square) from the webapp ? We need to look if it is something in a specific post that could be causing an unhandled case to cause this.

1 Like

Have you tried restarting your phone and trying again?

Hello, @Ewilaan

On top of the questions and suggestions made, we would also like to know the previous version that you were running on prior to the update that causes the Unexpected error occurred to surface. Was it 1.28 or 1.29?

In any case, you can check on either of them if you need to have the Android app running for communication purposes:

Keep us posted. Thanks.


Obviously, yes, I tried to restart my phone : no change.
I have the error with 1.30.0 version, no problem with 1.29.0… So : for the moment I’m staying in 1.29.

I’m the only one to have this error on my server. And I can’t take a screen, sorry.
Maybe a version problem with my phone ? My phone isn’t very old.

Hello, @Ewilaan

I have another user who is using the same device (OnePlus 5) with Android 9 facing the same issue. As mentioned by @amy.blais earlier:

Can you please confirm with the System Administrator (if you are the end user) on this?