Configuration options switch back when press save button


i will can’t change some settings because it switch back to default when i’m press save button, for example, i want to switch “Enable Account Creation” setting to false.

If i change “Enable Team Creation” to false it worked, but, can’t disable “Enable Account Creation” or if i feel SMTP server settings, it switch to empty after save button.

MTT deployed to local kubernetes kluster through helm chart

Hi @vmanyushin!

Thank you for reaching out.

Could you review this web page and send us the relevant additional information such as your server version, device, any logs, config files, etc. so we can diagnose this issue?

Do you see any errors in Developer Tools > Console?

Can you also verify that the user running the Mattermost server has write permissions on the config.json file?

Reinstall today MTT server to standalone RH7, all work good, seems it’s deploy to k8s problem…

The issue is not solved. Mattermost team + kubernetes. No console errors.
k8s 1.13.1-do.2
Mattermost from helm repo
mattermost/mattermost-team-edition 5.6.2

{“level”:“info”,“ts”:1547070795.952318,“caller”:“utils/i18n.go:78”,“msg”:“Loaded system translations for ‘en’ from ‘/mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1547070795.9571805,“caller”:“app/app.go:143”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1547070795.9600437,“caller”:“sqlstore/supplier.go:207”,“msg”:“Pinging SQL master database”}
{“level”:“info”,“ts”:1547070797.0999415,“caller”:“commands/server.go:82”,“msg”:“Current version is 5.6.0 (5.6.2/Sat Dec 22 14:58:39 UTC 2018/3aed6efc6bb5a67fdb8237aac38d46fab3266e8d/2c2d33b22b4c2938938eade4b9914748c1be9d3b)”}
{“level”:“info”,“ts”:1547070797.1000738,“caller”:“commands/server.go:83”,“msg”:“Enterprise Enabled: true”}
{“level”:“info”,“ts”:1547070797.1000998,“caller”:“commands/server.go:84”,“msg”:“Current working directory is /mattermost”}
{“level”:“info”,“ts”:1547070797.100166,“caller”:“commands/server.go:85”,“msg”:“Loaded config file from /mattermost/config/config.json”}
{“level”:“info”,“ts”:1547070797.1019926,“caller”:“filesstore/localstore.go:33”,“msg”:“Able to write files to local storage.”}
{“level”:“info”,“ts”:1547070797.1042979,“caller”:“app/license.go:44”,“msg”:“License key from required to unlock enterprise features.”}
{“level”:“info”,“ts”:1547070797.105763,“caller”:“app/plugin.go:130”,“msg”:“Starting up plugins”}
{“level”:“info”,“ts”:1547070798.4837222,“caller”:“app/server.go:168”,“msg”:“Starting Server…”}
{“level”:“info”,“ts”:1547070798.4852965,“caller”:“app/server.go:228”,“msg”:“Server is listening on [::]:8065”}
{“level”:“info”,“ts”:1547070798.5024097,“caller”:“app/web_hub.go:75”,“msg”:“Starting 2 websocket hubs”}
{“level”:“info”,“ts”:1547070798.5099773,“caller”:“sqlstore/post_store.go:1286”,“msg”:“Post.Message supports at most 16383 characters (65535 bytes)”}
{“level”:“info”,“ts”:1547070798.585491,“caller”:“jobs/workers.go:68”,“msg”:“Starting workers”}
{“level”:“info”,“ts”:1547070798.5873446,“caller”:“jobs/schedulers.go:72”,“msg”:“Starting schedulers.”}
{“level”:“error”,“ts”:1547070938.6159284,“caller”:“web/context.go:60”,“msg”:“Login failed because of invalid password”,“path”:"/api/v4/users/login",“request_id”:“54fkgnd617rn5yt8nfo1d4m94e”,“ip_addr”:“”,“user_id”:"",“method”:“POST”,“err_where”:“checkUserPassword”,“http_code”:401,“err_details”:“user_id=xx1c7o4bwbg3frenurojisx9mc”}

@cpanato Would you be able to help test this one?

The issue is that the users are not able to change some settings in the System Console, because they switch back to the default setting after pressing the “Save” button. This happens with, for example, “Enable Account Creation” setting.

They are using the Kubernetes cluster through helm chart.

If you are using the kubernetes you cannot change the config settings in the admin console, you will need to change in the config map and then recycle the pods

1 Like

Hello, @cpanato

I would assume that this would explain the following point in the Configuration section, specific to Mattermost Kubernetes:

To start, copy mattermost-helm/values.yaml and name it config.yaml . This will be your configuration file for the Mattermost helm chart.

which points to the yaml file. For example:

  enableTeamCreation: true
  enableUserCreation: true
  enableOpenServer: true
  enableLinkPreviews: false
  enableCustomEmoji: false