Copy Paste leads to JavaScript error

Hi there,

I have been trying to figure this out for 3 days with no success.
This happened to me after upgrading server from 5.8 to 5.15.

Steps to reproduce:

  1. Right click on any lotus notes document, select “Copy as document link”
  2. Click on mattermost chat, ctrl-v to paste.
  3. Notice that no text is pasted and the following appears on top
    “DEVELOPER MODE: A JavaScript error has occurred. Please use the JavaScript console to capture and report the error (row: 1 col: 906209)”

Before updating to 5.15:
1.I was able to use ctrl-v to paste the document link in text information. Results in something like this on mattermost:

 "ABCDE - Some Title
<NDL><REPLICA 49251111:002C1E2C>
<VIEW OF0B76CF11:5CE40511-ON49256C11:000BBC11>
<NOTE OFD6D21411:6E62F311-ON49258211:001E7311> 
<HINT>CN=notes-db/O=abcd</HINT> <REM>Database 'abcde', View 'PageName', Document 'DocementName'</REM> </NDL>"
  1. And the text is converted to some (notes:/link) thru autolink plugin.

Now, If it try to paste into a text editor like notepad, and then copy the text from notepad to paste into mattermost, the error message does no appear and my text gets displayed.

The error happens on desktop client, as well as webpage (firefox and chrome)


  1. How do i go about debugging the Javascript error?
  2. I tried to downgrade 5.15 -> 5.14… 5.11 and the error persisted. I failed to downgrade further down to 5.10 and 5.9 so I am unable to know if the feature broke for me at which versions.

I tried to open console debug in browser and i see this:

Uncaught TypeError: Cannot read property 'querySelectorAll' of undefined
webview.addEventListener.e @ index_bundle.js:28195

One more hint I have is that I am certain that the command “Copy as document link” within Lotus Notes copies something more that text into clipboard.

I tried a freeware called “Free Clipboard Viewer” and it does show several other objects other than text being copied in memory, However, this information does not really help me either.