[SOLVED] Cannot view incoming webhooks under integrations in UI


Incoming webhooks are not visible under integrations in the UI, and a 500 error is showing in the log when we attempt it.

Steps to reproduce

We are using Mattermost 4.9.2. The database is postgresql 9.6.

  1. Log in as an administrator.
  2. Select “Integrations” from the main menu
  3. Select “Incoming webhooks”

Expected behavior

The existing incoming webhooks should be displayed. (We have several, and they are all working correctly.)

Observed behavior

In the UI, the message No incoming webhooks found is displayed.
In the mattermost log, this error appears:

[2018/05/11 12:26:42 PDT] [EROR] /api/v4/hooks/incoming:SqlWebhookStore.GetIncomingByUser code=500 rid=czz1k4jnzbrq9eqwfpq8xii7bc uid=h34sb8j4xtyafqcmwow9u13nsy ip= We couldn't get the webhook [details: teamId=ic9syaqpa38r5jzggsq5qp33rh, err=sql: Scan error on column index 9: unsupported Scan, storing driver.Value type <nil> into type *string]

Hi @thejimnicholson,

Thank you for reporting this!

I tried the repro steps on our latest 4.10-RC and was not able to reproduce.

Did you recently upgrade to 4.9.2 and has the issue been there since upgrading (is it a new issue) or have you experienced this issue before?

Yes, it was an upgrade from 4.8.0, that apparently also had the problem after an upgrade from 3.x that occurred after I came onto the project. I’ve done a fresh install of 4.9.2 and I also can’t reproduce. I’m going to try and see if I can spot differences in the db.

Hi @thejimnicholson Following up on this - have you still experienced issues with this? Let me know if you need any further assistance or if you have any questions!

We dropped and recreated the database, and the problem disappeared. We can now see webhooks that we’ve created.

We suspect that something went amiss in the course of some of the upgrades from 3.x to 4.x, but I have no specific things to point at.

1 Like